Rob Kraft's Software Development Blog

Software Development Insights

IIS 5.1 on Windows XP does not a good Silverlight test server make

Posted by robkraft on November 4, 2010

Today we resolved a few problems in our Silverlight application that manifested as [Async_ExceptionOccurred] and “Remote server not found” errors.  Our testing server was running IIS 5.1 on Windows XP.  IIS on Windows XP is limited to just 10 connections.  Since IE8 may be using up to 6 connections at a time, and during testing we often have multiple users, the maximum number of connections is exceeded and errors occur.  We found HTTP response code 403 (http://en.wikipedia.org/wiki/HTTP_403) in the logfiles of the IIS server.  I guess that we specifically were getting 403.9 “Too many users”, but that detail is not included in our log file.  Using Fiddler we saw some of the errors as 504 (the very same requests that IIS logged as 403).  The 504 did not seem accurate though because the failure response occurred immediately and our WCF timeouts are all set to 10 minutes.

 I thought I’d post what we found hoping it hastens others experiencing similar problems to a resolution.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: